Foire aux questions

Message "Erreur d'encodage de contenu"

Si lors d'un changement de version de PHP  sur votre site vous observez le message "Erreur d'encodage de contenu" ceci est dû à un module incompatible avec la version de PHP choisi avec la compression GZIP activée.

Pour résoudre ce point : 

  • Revenez à la version PHP précédente
  • En administration dans Système/configuration/Serveur, Mettre la compression GZIP sur Non
  • Revenir sur la nouvelle version de PHP
  • Sur la page système s'affiche un message d'erreur qui vous indique le module incriminé
  • Désactiver ce module ou le mettre à jour avant de réactiver la compression GZIP

Problèmes constatés sur les plugins :

JDUMP Migrer vers la version 1.2.3

JDATE Dans le fichier HD_Date.php  situé dans www/plugins/system/hd_Date/  remplacer ligne 15
class plgSystemHD_Date extends JPlugin
{function plgSystemHD_Date(&$subject, $config)    {parent::__construct($subject, $config);    
$this->_plugin = JPluginHelper::getPlugin( 'system', 'HD_Date' );}
par
class plgSystemHD_Date extends JPlugin
{function __construct(&$subject, $config)    {parent::__construct($subject, $config);    
$this->_plugin = JPluginHelper::getPlugin( 'system', 'HD_Date' );}


Retour